Автор Тема: Не обновляется с 3.12 до 3.13  (Прочитано 3819 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн apostal86

  • Местный лис
  • ***
  • Сообщений: 109
  • Авторитет: 5
    • Просмотр профиля
Не обновляется с 3.12 до 3.13
« : 21 декабря 2016, 12:11:10 »
Та же проблема, но другая ошибка у другого сайта при попытке обновиться с 3.12 на 3.13:

Fatal error: Call to undefined method kernel::pub_user_ip_get() in /home/u21263/www.мой_сайт/www/include/security.class.php on line 502

См. скрин



При этом сайт "умер", оставив после себя лишь ошибку, сделал только скрин



Благо восстановление архива на хостинге спасло ситуацию. Как оказалось, штатное копирование почему-то не сработало.

Но вопрос остался. Что не так для обновления? Чего не хватает?
« Последнее редактирование: 21 декабря 2016, 12:55:43 от apostal86 »

Оффлайн bubek

  • Старый лис
  • *****
  • Сообщений: 615
  • Авторитет: 55
  • Пол: Мужской
    • Просмотр профиля
Re: Не обновляется с 3.12 до 3.13
« Ответ #1 : 21 декабря 2016, 14:01:08 »
После обновления необходимо  Переинсталировать языковые переменные

Оффлайн apostal86

  • Местный лис
  • ***
  • Сообщений: 109
  • Авторитет: 5
    • Просмотр профиля
Re: Не обновляется с 3.12 до 3.13
« Ответ #2 : 21 декабря 2016, 14:59:49 »
После обновления необходимо  Переинсталировать языковые переменные

А как я это сделаю? Если Вы прочитали, то после ошибки сайт "умирает", и уже ничего кроме восстановления из бэкапа на хостинге не получается сделать.

Мне кажется по ошибке, что инсталяция до конца не добирается, если все потом рушится

Оффлайн bubek

  • Старый лис
  • *****
  • Сообщений: 615
  • Авторитет: 55
  • Пол: Мужской
    • Просмотр профиля
Re: Не обновляется с 3.12 до 3.13
« Ответ #3 : 21 декабря 2016, 15:36:41 »
Да, недочитал :)
Проверил обновление у себя, все нормально обновило.

Нужно было закинуть файл frontoffice_manager.class.php с версии 3,13 по фтп
Может прав не хватает на переписывание файлов, но в таком случае одним файлом не ограничится.
« Последнее редактирование: 21 декабря 2016, 15:43:19 от bubek »

Оффлайн Oslix

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 2 472
  • Авторитет: 346
  • Пол: Мужской
    • Просмотр профиля
Re: Не обновляется с 3.12 до 3.13
« Ответ #4 : 21 декабря 2016, 17:12:26 »
Лучше на всякий случай по фтп переписать файлы.

Оффлайн apostal86

  • Местный лис
  • ***
  • Сообщений: 109
  • Авторитет: 5
    • Просмотр профиля
Re: Не обновляется с 3.12 до 3.13
« Ответ #5 : 21 декабря 2016, 17:41:33 »
Да, недочитал :)
Проверил обновление у себя, все нормально обновило.

Нужно было закинуть файл frontoffice_manager.class.php с версии 3,13 по фтп
Может прав не хватает на переписывание файлов, но в таком случае одним файлом не ограничится.

Когда обновлял на 3.12, то прав на все хватило. Права больше с тех по не менялись.

Оффлайн apostal86

  • Местный лис
  • ***
  • Сообщений: 109
  • Авторитет: 5
    • Просмотр профиля
Re: Не обновляется с 3.12 до 3.13
« Ответ #6 : 21 декабря 2016, 17:41:54 »
Лучше на всякий случай по фтп переписать файлы.

Какие именно файлы

Оффлайн Oslix

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 2 472
  • Авторитет: 346
  • Пол: Мужской
    • Просмотр профиля
Re: Не обновляется с 3.12 до 3.13
« Ответ #7 : 21 декабря 2016, 18:52:13 »

Оффлайн apostal86

  • Местный лис
  • ***
  • Сообщений: 109
  • Авторитет: 5
    • Просмотр профиля
Re: Не обновляется с 3.12 до 3.13
« Ответ #8 : 21 декабря 2016, 19:36:49 »
Да, недочитал :)
Проверил обновление у себя, все нормально обновило.

Нужно было закинуть файл frontoffice_manager.class.php с версии 3,13 по фтп
Может прав не хватает на переписывание файлов, но в таком случае одним файлом не ограничится.

С версии 3.12

https://bitbucket.org/Oslix/santafox-cms/downloads/santa3.12.zip

Противоречивые ответы просто запутали. Так откуда брать файлы с указанного репозитория версии 3.12 или все-таки с 3.13

Оффлайн Oslix

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 2 472
  • Авторитет: 346
  • Пол: Мужской
    • Просмотр профиля
Re: Не обновляется с 3.12 до 3.13
« Ответ #9 : 22 декабря 2016, 10:14:49 »
ой. да. с 3.13 конечно же. Сорри, забыл о какой версии речь идет :)